raynix 筆記

raynix 筆記

  • Home
  • WordPress Hosting
  • Side Quests
Illustration of a bird flying.
  • [ Solved ] Google Cloud SQL MySQL Error When Setting Flags for Read Pools

    A read pool in a Google Cloud SQL MySQL cluster is a fully managed group of read replicas which can auto-scale based on server metrics such as CPU utilisation. Recently I gave it a try and replaced existing read replicas with a read pool. Everything went well until when setting flags. I manage Cloud SQL…

    September 30, 2026
    Systems Admin
    Cloud SQL, mysql
  • My Marathon Upgrade For External Secrets Operator

    I haven’t done an upgrade for my External Secrets Operator(ESO) for a while in my Kubernetes clusters. The version stayed at 0.5.x for 4 years already 😛 Lucky for me, AI/Claude has become hugely helpful now. So I asked Claude to summarise the upgrade path I should take – I guess a big quick hop…

    August 24, 2026
    Systems Admin
    ExternalSecret, kubernetes
  • [ Solved ] Regex Rules in HTTPRoutes Silently Dropped by Istio

    In my recent journey to adopt Gateway API in GKE clusters in production environments, I encountered a quite weird issue: When there are the default catch-all route and some regex routes defined as HTTPRoutes, the regex ones are silently dropped causing those requests to go through the default route unexpectedly. For example, for the following…

    June 10, 2026
    Systems Admin
    Gateway API, istio, kubernetes
  • [ Solved ] Service kubelet Can’t Start After Upgraded to 1.35

    When upgrading my home-lab Kubernetes cluster from 1.32 to 1.35, I encountered some error that the first node upgraded became not ready, eg. It should show 1.35 but it didn’t. I guess there should be some error in the logs of the kubelet service. So this –pod-infra-container-image flag needs to be removed. Easy. I probably…

    May 12, 2026
    Systems Admin
    kubeadm, kubernetes
  • [ Solved ] kube-apiserver Kept Crashing

    I planned to upgrade my home-lab Kubernetes cluster from 1.32 to 1.35, using the same shortcut I used last time. Unfortunately when I took a look at the cluster which I didn’t touch for a while, I couldn’t connect to it anymore. It’s not convenient at all – I can’t use kubectl to troubleshoot the…

    May 11, 2026
    Systems Admin
    kubeadm, kubernetes
  • [ Solved ] `33554536:system library:OPENSSL_internal:Connection reset by peer` Error with GCLB + Gateway API + OSS Istio

    I was trying to get a PoC of Google global external load-balancer to work with Gateway API and Istio as gateway class running in a standard GKE cluster. Everything was working as expected except I got My setup looks like below First I tried to test if the request can be served by the gateway:…

    February 19, 2026
    Systems Admin
    Gateway API, Google Cloud, istio
  • [ Solved ] WiFi Kept Disconnecting in Arch Linux

    Since my home WiFi 6e upgrade, my Alienware laptop running Arch Linux couldn’t connect to WiFi anymore. To be precise, it could connect but just kept disconnecting. I didn’t have the appetite to troubleshoot it until recently. When I looked into the system logs, I saw a lot of things going on but basically iwd…

    February 12, 2026
    Opensource
    Arch Linux, iwd
  • How to Test a Terraform Provider Locally

    In a .tf file, in a required_providers block all the Terraform providers will be listed there. When terraform plan is executed the providers will be pull from a registry or cache if defined. But how to test a provider that’s not published to a registry yet? Say the provider is called raynix so normally we’d…

    December 18, 2025
    Systems Admin
    Terraform
1 2 3 … 111
Next Page→
  • Eric Lin’s Blog
  • Eddie Wang’s Blog at WP
  • GoalKeeper’s Blog

raynix 筆記

Just another WordPress blog

  • Facebook
  • Twitter
  • Instagram

Proudly powered by WordPress