让Ubuntu Server为Drupal7做好准备

Drupal7 在各方面都让我眼馋, 今天我将D7的dev版装到测试服务器上, 结果发现出了这个问题:

貌似Ubuntu Server自带的GD有点落伍了. 按照提示重新编译PHP5? 那太伤神了. 还好, Drupal站上已经有人解决了此问题:

PHP GD library on Ubuntu Server 8.04.x LTS

具体步骤如下:

首先, 清理掉现有的GD
sudo apt-get --purge remove php5-gd
将下面的源加入到系统 /etc/apt/sources.list
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

更新apt数据库
sudo apt-get update
安装新的GD库
sudo apt-get install php5-gd
之后会有一些问题, 全部按缺省, 继续即可. 然后可以重新启动的你apache2了

sudo /etc/init.d/apache2 restart

看结果

🙂

Leave a Reply

Your email address will not be published. Required fields are marked *